A Brief But Accurate Documentation, BSD Linux And Programming

 Docker

Saturday, May 6, 2017

FreeBSD/GhostBSD Nvidia Installation

Nvidia driver installation

To play games or use 3D CAD software you need to install Nvidia driver.

Install using ports

Download the GhostBSD 10.3 kernel source code for i386 or x86_64.
Download the GhostBSD 11.0 kernel source code for i386 or x86_64.

Unpack it in the directory /usr/src.
Update you ports tree:
portsnap fetch update
Get inside needed driver (ex. nvidia-drivers-304):
cd /usr/ports/x11/nvidia-drivers-304
Compile it
make install clean
Install nvidia-xconfig utility and create xorg.conf file with it
cd /usr/ports/x11/nvidia-xconfig
make install clean
nvidia-xconfig

Install using package manager

First you should search for available drivers packages:
pkg search nvidia
you will get something like this:
nvidia-driver-367.44_3         NVidia graphics card binary drivers for hardware OpenGL rendering
nvidia-driver-304-304.131_4    NVidia graphics card binary drivers for hardware OpenGL rendering
nvidia-driver-340-340.96_4     NVidia graphics card binary drivers for hardware OpenGL rendering
nvidia-settings-375.26_3       Display Control Panel for X NVidia driver
nvidia-texture-tools-2.0.8.1_7 Texture Tools with support for DirectX 10 texture formats
nvidia-xconfig-375.26          Tool to manipulate X configuration files for the NVidia driver
Now choose driver and install it:
pkg install nvidia-driver-340-340.96_4
If you want to install the latest nvidia driver just enter:
pkg install nvidia-driver
this will install driver version 367.44_3 but there is a slightly different step needed to set it up for GhostBSD. See next section below.
Also we need to install two additional packages:
pkg install nvidia-settings
pkg install nvidia-xconfig

Setting up GhostBSD/FreeBSD to use nvidia

If you use and AGP nvidia card run the next command.
echo 'hint.agp.0.disabled="1"' >> /boot/device.hints
Note:
  1. Using GhostBSD GRUB the driver must be loaded in /etc/rc.conf:
    echo 'kld_list="nvidia"' >> /etc/rc.conf
  2. For nvidia drivers later than 367.35 this must be loaded in /etc/rc.conf:
    echo 'kld_list="nvidia-modeset"' >> /etc/rc.conf
  3. Using BSD loader or Linux Grub the driver must be loaded in loader.conf:
    echo 'nvidia_load="YES"' >> /boot/loader.conf
  4. For the latest nvivia driver (after 367.35) this must be loaded:
    echo 'nvidia-modeset_load="YES"' >> /boot/loader.conf

Make X configuration file with nvidia-xconfig utility:
nvidia-xconfig
You can reboot your system now:
reboot

No comments:

Post a Comment

Back to top